Import WPs: Symbol nicht gefunden

  • Hallo,
    auch mit der neuen Version bekomme ich beim Import einer KML-Datei folgenden Fehler: Die POI-BMP wird nicht gefunden (in 1.0.7.2) hat das noch funktioniert.

    Gruß Bernd


  • Hallo,

    es muss da irgendwo eine Änderung bei einem Update gegeben haben. Hatte letzten November schon mal ein Thema gestartet. Da hat es funktioniert, leider nicht fehlerfrei.

    Siehe: Übernahme von Wegpunkten mit eigenen Stilsymbolen nach QVX

    Habe seitdem die Funktion nicht mehr genutzt, weil es leider nicht richtig geht. Nerv! :mh:


    Ich habe jetzt die gleiche WP Tabelle als gpx und als kmz in QV7 exportiert und in QVX wieder importiert.


    Der Import läuft durch, aber es werden keine eigenen Symbole mehr angezeigt. Ist wie bei Dir, Bernd: Es kommt beim Stil der Hinweis "Name.bmp nicht gefunden".

    Anscheinend wird der Pfad der eigenen Symbole nicht mehr gefunden. Eine Möglichkeit, diesen irgendwie einzustellen, gibt es anscheinend auch nicht.


    Viele Grüße

    Lothar

  • Sicher Fehler, in der Ecke hab ich einiges geändert.

    Schickst Du mir die kml nochmal?

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • ist gefixt

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Hallo,


    das überzeugt mich noch nicht.


    die eigenen Symbole werden nur im Ordner C:\Users\Public\Documents\QVX_Data\Symbols ausgelesen. Das Original Verzeichnis wird beim Import nicht mitgezogen.



    Beim Versuch, im Symbolset bei "Import" einen anderen Ordner zu verwenden, wird immer wieder der C:\Users... Ordner verwendet. Sind dort keine Dateien, kommt eine Fehlermeldung.


    Damit ließe sich ja leben.


    Aber leider muss jedem Wegpunkt einzeln der Stil wieder zugewiesen werden. Bei hunderten von Punkten geht das nicht.

    Bernd: bei Dir waren es fast 13.000 WP, viel Spaß 8o


    Immerhin werden die Symbole jetzt wieder vollständig angezeigt.


    Viele Grüße

    Lothar

  • Hallo,

    Aber leider muss jedem Wegpunkt einzeln der Stil wieder zugewiesen werden

    als workaround kannst Du die KML vor dem Import in QVX in einem Texteditor öffnen und alle Pfadvorkommen auf den neuen Pfad ändern.

    Mit dem Notepad++ geht das auf einmal. Ist also nicht viel arbeit.


    Gruß

    Horst

  • Hallo Horst,


    ja, solche Basteleien gehen sicher. Die WP Liste mit meinen eigenen Symbolen erstelle ich über Excel. Da werde ich dann den neuen Pfad reinbasteln. Ich hoffe, dass die Symbole dann auch angezeigt werden.


    Es scheint so zu sein, dass beim "Import" des Symbolset Stils eine ausgewählte Bilddatei in den C:/Users... Ordner kopiert wird. Daher also kein neuer Ordner. Musste ich erst mal verstehen.



    Viele Grüße

    Lothar

  • Aufpassen. Es gibt 100 verschiedene Wege, wie Symbole auftauchen und benutzt werden können

    Beim Kmz-Import liegen die bitmaps im Kmz, die werden dann einfach direkt mit dem WP gespeichert, dazu braucht es kein Symbol in QVX_Data\Symbols

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Hallo Tom,

    Danke für den Hinweis.


    Bei mir geht es bis jetzt nur darum, WP mit eigenen Symbolen aus einer Excel Tabelle nach QV (7-X) zu bekommen.


    Hatte mir das für QV7 zurechtgebastelt und möchte das natürlich auch in gleicher Qualität in QVX nutzen können. Ist jetzt im Sommer nicht so viel Zeit für den Rechner, aber ich werde das demnächst mal angehen.

    Viele Grüße

    Lothar

  • Hallo nochmals,


    ich stehe da gerade mal auf dem Schlauch... <X



    Wie importiere ich eine .csv Datei nach QVX?


    Geht in QV7 problemlos, aber im QVX finde ich es nicht.

    Da ich jetzt unterschiedliche WP Tabellen in QV7 und QVX habe, würde ich natürlich gern die entsprechende auch direkt in QVX importieren.


    Das möglichst ohne Basteleien und Umwege. 8o


    Viele Grüße

    Lothar

  • csv ist noch nicht drin in QVX.

    Da ich jetzt unterschiedliche WP Tabellen in QV7 und QVX habe, würde ich natürlich gern die entsprechende auch direkt in QVX importieren.

    Da brauchst Du doch kein csv für. Geht doch direkt über qvmdb-export

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Quote

    Da brauchst Du doch kein csv für. Geht doch direkt über qvmdb-export

    Nein.

    In QV7 haben meine Symbole einen anderen Pfad. Ich kann natürlich in QV7 auch den Pfad für QVX benutzen (geht einwandfrei) und dann als qvmdb exportieren. Ist aber etwas unübersichtlich. Na gut.:/

    Deswegen der Export aus Excel als .csv.


    Der qvmdb Import nach QVX läuft aber so immer noch nicht richtig rund:


    - Umlaute werden nach wie vor im Tabellennamen nicht angezeigt (Leerzeichen)

    Hatten wir hier schon mal diskutiert. Ist vielleicht auch eine Macke beim Export aus QV7


    - Die Symbole werden zwar gezogen aber nicht als Stil in der Explorertabelle angezeigt.

    Wenn ich etwas in den Symbolen herumklicke, erscheinen willkürlich nach und nach einzelne Symbole in der Spalte "Stil"


    - Auf der Karte scheinen die Symbole immer noch rechts und unten abgeschnitten zu sein.

    Wie groß sollten die Symbole optimal sein? Hatte bisher 32x32 Pixel, ist vielleicht zu klein?


  • schick mir mal genau diese db

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Danke.


    Daß das "ä" im Tabellennamen fehlt und die Symbole abgeschnitten sind, liegt leider an QV7.

    Irgendwie ist da in QV7 32x32 fest eingetragen.



    Daß sie nicht im Xplorer in der Liste angezeigt werden, liegt an QVX, das ist gefixt.

    Das kannst Du jetzt schon selber ändern, indem Du einfach alle WPs markierst und dann im Stil die beiden Haken bei den Farben raus nimmst.

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Ok, das hat funktioniert.


    Quote

    Irgendwie ist da in QV7 32x32 fest eingetragen.

    Gibt es für QVX eine optimale Symbolgröße (die dann auch komplett angezeigt wird) ?

  • Gibt es für QVX eine optimale Symbolgröße (die dann auch komplett angezeigt wird) ?

    --- gelöscht ---


    Habe das gerade ,mal mit QV7 getestet ...


    Tom,

    Warum wandelst Du eigene Symbole nicht in voller Pixelzahl um?


    Gruß

    Horst

    Edited once, last by Horst_H ().