Kein Download von Tracks beim Garmin 66st

  • Guten Tag! Ich kann zwar Tracks und Waypoints auf mein Garmin 66st hochladen, aber beim Herunterladen bekomme ich folgende Fehlermeldung:


    Garmin GPSMAP 66ST Software 250, als Laufwerk F:\ verbunden

    F:\Garmin\GPX\Current\Current.gpx

    System.NullReferenceException


    Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.


    bei aj.e()

    bei QV70.clsImportExport_GPX_11.get_Tracks()

    bei QV70.ImportExport.h()

    bei a8.a(clsBackgroundTask A_0, Int32 A_1, eImportFlags A_2, IQDB A_3, List`1& A_4)

    Error while downloading: IOError

    Done, time=0,14s


    Bei meinem vorherigen Gerät, Garmin 64, gab es keine Probleme.

    Ich verwende Windows 10 auf dem iMac und QV 7.


    Schönen Gruß, Paul

    :(:(;(

  • Um den Fehler einzugrenzen: Kannst du Current.gpx mit dem Windows Explorer auf dein Notebook kopieren ? Und geht es dann diese Kopie in TTQV zu importieren ?

    Möglicherweise hilft auch ein Update der Firmware des 66ST auf die aktuelle Version 420.

  • current.gpx auf den Computer kopieren und dann in QV importieren ging auch nicht. Aber ich habe jetzt mal mit Garmin Express ein komplettes Update des Geräts durchgeführt und siehe da - jetzt klappt es plötzlich. Danke für den Hinweis!

  • :thumbup:

    "Wenn Du tust, was Du immer getan hast, wirst Du bekommen, was Du immer bekommen hast!" Abraham Lincoln

  • Hallo *,


    ich habe das gleiche Problem, der update auf die Software 4.2 hat nicht geholfen.

    QuoVadis 7.4.0.5 - Standard, GPS66S mit Software 4.20


    a) "Empfangen von GPS" bringt "Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt." Dabei kann ich Schritt 4/4 zigmal klicken, es passiert nichts, er zählt die Daten/Tracks hoch und dann kommt die Fehlermeldung.


    b) Import - hier lädt er mir nur einen Bruchteil der Daten. (Auffällig mag sein, dass es je ein Datensatz in Track und mit gleichem Namen in Training ist. Da gibt es aber sicher noch mehrere. Daher glaube ich nicht daran.) Was aber funktioniert ist, dass ich jedes File einzeln hochladen kann - aber das ist logischerweise müßig, er will immer für jedes GPX eine neue Datenbank anlegen.


    Danke und Viele Grüße

    nicktech

  • Was hast du unter Einrichten->Aufzeichnung->Erweiterte Einst.->Ausgabeformat eingestellt ? Da sollte "FIT und GPX" stehen. Sonst speichert das Teil deine Aktivitäten ( angesehen von current.gpx, also der laufenden Aufzeichnung) nur im FIT Format ab. Mit dem QV7 nicht viel anfangen kann. Ich gehe jedenfalls so vor : GPS Fix abwarten, dann: Aufz.steuerungen-> Verwerfen, dann am Ende der Tour Aufz.steuerungen->Speichern. Und habe dann einen Track im gpx-Format mit Zeitstempel im Namen, den ich mit QV7 importieren kann.

  • Danke mkossmann. Ja, das habe ich auch, "FIT & GPX".


    Was ich noch probiert habe:

    1) Import: ungültige Punkte ebenfalls importieren -> klappt nicht

    2) alle GPX von G:\Garmin\GPX auf ein anderes Laufwerk des Computers kopiert und von dort versucht einzubinden - QV übernimmt wieder nur einen Bruchteil der GPX Files, aber immerhin die gleichen. Es scheint damit kein direkt mit Garmin verbundenes Problem zu sein ?

    3) nur eine begrenzte Zahl GPX Files ausgewählt (Idee dahinter: a) alles Files die das Garmin erstellt hat, oder b) nur geplante Files, c) beides ), es kommt "Importing D:\...\Neuer Ordner\*.gpx Done, time=0,15s" --> QV nennt ein File und nicht die hier fünf ausgewählten Files, sagt done, erstellt aber keine Datenbank.

    4) bei "von GPS empfangen" habe ich die Haken bei "Garmin Flash" und "GPSMAP 66S Software 420 als Laufwerk verbunden" je einzeln und alle gesetzt - ohne Erfolg

  • Könntest du mal mindestens eine der gpx-Dateien , denen sich QV7 verweigert, zippen und als Anhang hier hochladen ?

  • Diesen Track kann ich ebenfalls importieren. Eigentlich habe ich aber nach einen Track gefragt, den du nicht importieren kannst. Jedenfalls habe ich

    Quote

    QV übernimmt wieder nur einen Bruchteil der GPX Files, aber immerhin die gleichen.

    so verstanden, daß auch immer die gleichen Tracks nicht importiert werden können. Auch nicht einzeln.

  • das importieren von einzeln ausgewählten tracks klappt - immer - da war meine Eingangs-Problembeschreibung wohl nicht eindeutig genug, sorry.

    das importieren aller tracks auf einmal klappt nicht, es wird immer nur eine kleine Teilmenge importiert.

  • 1) Ich habe versucht die Dateien in basecamp zu laden. Bis auf zwei, bei denen es eine Fehlermeldung gab (die ich nicht lesen konnte, das sie abgeschnitten wurde), klappte das. Habe diese zwei in QV aber weggelassen, hat das nichts gebracht.


    2) Was ist mittlerweile sagen kann:

    wenn ich versuche alle Dateien zu importiere,

    dabei aber die Files des Formates z.B. 2020-02-16 204512.gpx; 2020-06-01 131722.gpx; ... auslasse,

    dann klappt es. Diese Dateien sind die im Garmin Gerät erzeugten tracks. In basecamp konnte ich diese laden. Einzeln kann ich eine solche Datei importieren.


    3) Seltsam sind noch die Trainingsdaten. Ich habe bisher nie mit diesen gearbeitet, daher mag es eventuell auch normal sein. Seltsam finde ich es in zweierlei Hinsicht:

    q) import der CIQ Files, z.B. CIQ_2020-07-18-19-24-12.gpx bringt eine Fehlermeldung, z.B. "> 'gpxx' ist ein nicht deklariertes Präfix. Zeile 70, Position 18. Please check input-file at line 70 at position 18"

    b) bei Vorgang 2) wurden auch Trainingsdaten mit eingebunden, diese tauchen im Ordner "Neue Trainingstabelle" auf, doch für manchen track habe ich sicher keinen Brustgurt getragen.

    Wie geschrieben, mit Training habe ich bisher nicht gearbeitet, ich schreibe auf, was ich bemerke, gehe dem aber momentan nicht nach.

  • Ich habe versucht das Problem nachzustellen. Leider ohne Erfolg. Alle 10 Tracks mit Standarddateinamen (yyyy-mm-dd hhmmss.gpx) ausgewählt und vom Gerät Im Massenspeichermodus nach in eine "neue Datenbank" importiert. Ging problemlos. Entstanden sind dabei 10 Einträge in der "neue Tracks" Tabelle und wenn man das Häkchen auch bei "Trainings importieren" ebenfalls 10 Einträge in der Trainingstabelle.

    Eine Frage noch : die bei dir problematischen Tracks scheinen vom Zeitstempel etwas älter zu sein. Kann es sein, das sie noch mit einer älteren Firmwareversion geschrieben wurden ?

  • mkossmann, vielen Dank. Die Frage nach der Firmaware-Version kann ich nicht sicher beantworten. Vermutlich aber ja.


    Ich habe derweil die SD Karte formatiert (weil ich zu spät realisiert habe, dass dort ja gar keine tracks abgelegt werden). Hier https://www.navigation-profess…r-dateien-garmin-outdoor/ habe ich gelesen, dass tracks aus dem Internet nicht im internen Speicher abgelegt werden sollen - die Intention ist dort aber eher Betriebssicherheit (Umgang mit defekten tracks - diese können dazu führen, dass das Gerät gar nicht mehr startet, wenn diese im internen Speicher liegen). Dennoch habe ich jetzt alle tracks in den Verzeichnissen "Activities" und "GPX" gelöscht.


    Jetzt werde ich die nächsten Tage mal tracks erzeugen und dann das Ganze nochmals probieren.


    Eine Anekdote am Rande: ich habe die 32GB Speicherkarte mit Windows Bordmitteln in FAT232 formatiert und *garmin* genannt und im Ordner Garmin meine Karte.img abgelegt. Allerdings wurde mir die Speicherkarte nicht angezeigt wenn ich das 66er mittels USB an den Rechner angeschlossen habe. Und ich konnte die Karte.Img am 66er folglich auch nicht aufrufen. Dann habe ich die SD Karte umbenannt, ohne "Garmin" im Namen und dann ging es. Ich schreibe es hier auf, weil meine Suche für dieses Thema nicht sehr ergiebig war, vielleicht hilft es jemanden.